症状を探し、解決方法の列のとおりに試します。それでも解決しない場合は、下記「ログを見る」で記録を確認します。
| 症状 | 原因 | 解決方法 |
|---|
| インストールが終わらない、またはファイルを置き換えられないというエラー | エディターが起動しています。 | エディターを閉じて、インストーラーを再実行します。 |
| 起動するとログイン画面しか表示されない | ログインが必要な一部の公開インストール版です。 | 招待されたアカウントでログインします。アカウントがない、またはパスワードを忘れた場合は、招待してくれた人に問い合わせます。 |
| 「ログインの確認に失敗」 | サーバーに接続できません。 | インターネット接続を確認します。一度ログインしていれば、7 日間はインターネットなしで開けます。 |
| 使用中にエディターがロックされた | 6 時間ごとのアカウント確認で、利用停止されたアカウントです。 | ロックされる前に自動保存されます。招待してくれた人に問い合わせます。 |
| AI 接続(MCP)サーバーがすぐに終了する | ログインが必要なインストール版で、エディターのログイン情報がありません。 | 先にエディターでログインします。AI 接続 (MCP) を参照。 |
| 症状 | 原因 | 解決方法 |
|---|
| 「Minecraft <バージョン> のクライアント jar が見つかりません」 | ランチャーフォルダーにそのバージョンの jar がありません。 | ランチャーでそのバージョンを一度起動します。次に ファイル › ランチャーフォルダーを再検索 (バージョン一覧) をクリックします。または ファイル › jar を読み込む… で jar を直接選びます。 |
| ブロックがテクスチャなしの色ボックスで表示される | jar を読み込めなかったか、そのブロックが現在の jar にありません。 | まず上記の jar の解決方法を行います。ステータス通知の「この jar にないブロック N種」の一覧を確認します。 |
| 別バージョンの jar に切り替えたら一部のブロックが崩れて表示される | そのバージョンにない新しいブロックか、名前が変わったブロックです。 | 0.9.10 以降は、名前だけが変わったブロック(sign ↔ oak_sign・grass_path ↔ dirt_path・grass ↔ short_grass・chain ↔ iron_chain)をその jar の名前で描画します。そのバージョンにないブロックは、この PC にあるより新しい jar の画像で表示し、通知を表示します。より新しい jar がない場合は色ボックスで表示されます。そのブロックは対象バージョンのゲームには存在しないため、置き換えてください。 |
| 「ブロックリスト (サーバーレポート) がありません」 | そのバージョンのブロック一覧のキャッシュがありません。 | ファイル › サーバー jar からブロック一覧を作成… (対象バージョン) でサーバー jar を選びます。バージョンごとに一度、数十秒かかります。 |
| 「java が見つかりません」 | ブロック一覧を作成するための Java がありません。 | Java をインストールして JAVA_HOME を設定するか、PATH に追加します。サーバーを動かせる Java であれば構いません。 |
| 対象バージョンの一覧に新しくインストールしたバージョンがない | 起動時に一度だけ検索します。 | ファイル › ランチャーフォルダーを再検索 (バージョン一覧) をクリックします。MOD ローダー(Forge・Fabric など)のフォルダーは一覧に表示されません。 |
詳しくは Minecraft バージョン を参照してください。
| 症状 | 原因 | 解決方法 |
|---|
| ショートカットがまったく効かない | コンソール・検索欄のようなテキスト欄にカーソルがあります。 | ビューポートを一度クリックします。テキスト欄でも Ctrl+S のような一部のキーは動作します(ショートカット を参照)。 |
| ショートカットが効かず「別のキーに移動しました」という通知が出る | その機能のキーをショートカットウィンドウで変更しました。 | ツール › ショートカット… で現在のキーを確認するか、「デフォルト」をクリックします。 |
| ワールド編集のキーが効かない | ペイントタブが表示されています。 | Ctrl+Tab でワールドタブに戻ります。 |
| プレイ中に編集キーが効かない | プレイ中は編集のショートカットが無効になります。 | Esc でプレイを終了します。 |
| W・E・R のギズモが表示されない | 何も選択されていません。 | Q で選択ツールを選び、範囲・プロップ・アクターを選択してから押します。 |
| 大きな作業中に他の編集・保存ができない | 20 万マスを超える作業は、複数フレームに分けて適用します。実行中は他の編集と保存が無効になります。 | ステータスバーの進行状況が終わるまで待つか、Esc・ステータスバーのキャンセルボタンでキャンセルします。キャンセルすると、適用済みの部分も元に戻します。 |
| 空を指して配置するとブロックがカメラの前にできる | ブロックがない場所では床(y = 0)、床も見えない場合はカメラの前方 6 マスの空中に配置します。 | 地面かブロックの面を指して配置します。 |
| ドラッグボックスの高さが下に下がらない | 0.9.9 以前の動作です。 | 0.9.10 以降にアップデートします。 |
| これ以上元に戻せない | 元に戻すの履歴は最大 200 ステップです。編集 › 履歴を消去 を行うと履歴が空になります。 | ウィンドウ › 履歴 パネルで残りのステップを確認します。重要な時点はクイックスナップショット(Ctrl+Alt+S)で残しておきます。 |
| 天井・空中の板の下をクリックしたのに木が上に植えられる | 0.9.10 以前の動作です。 | 0.9.11 以降は、クリックした層(天井の下の床)に植えます。 |
| 症状 | 原因 | 解決方法 |
|---|
| 読み込んだ OBJ・FBX・glTF モデルがリソースパックから抜けている | 「元の形」(三角形)で読み込んだため、Minecraft のモデルにできません。 | コンテンツブラウザでモデルを右クリック › 「読み込み方式を変更…」で「ディスプレイ」または「ブロックに変換」を選びます。0.9.9 以降は、リソースパックの作成時にディスプレイへ自動変換して警告します。 |
| UV エディターで OBJ・FBX・glTF を編集できない | UV の編集は .bbmodel・.npmodel・カスタムブロックでのみ可能です。 | UV を編集するモデルは .bbmodel で読み込みます。 |
詳しくは カスタムモデルの読み込み・リソースパックと HUD を参照してください。
| 症状 | 原因 | 解決方法 |
|---|
| 大きなマップで重い・カクつく | 描画距離・影の距離が PC の性能に対して大きすぎます。 | ツール › パフォーマンス設定… で「低スペック PC」プリセットをクリックします。Ctrl+F7 のパフォーマンス表示で FPS とメッシュ化キューを確認します。 |
| 開いた後しばらく遠くが空白に見える | チャンクのメッシュを作成中です。 | ステータスバーの「メッシュ化」の数が 0 になるまで待ちます。メッシュ生成スレッドを増やすと速くなります。 |
| F6 のゲーム画面が以前の近似画面で表示される | Forward+ レンダラーを使えない環境です。 | グラフィックスドライバーを最新にします。 |
| F7 のパストレーシングが動かない | コンピュートシェーダーを使えない環境です。 | グラフィックスドライバーを最新にします。 |
| 遠くからマップ全体を見ると F6 で地形が空色になって消える | ゲームの描画距離の端のフォグです。 | ビューポートバーの「大気・ライティング」パネルの「ゲーム画面 (F6) 表示」で「描画距離 (チャンク)」を伸ばすか、「俯瞰モード (エディター専用)」をオンにします(0.9.1 以降、既定でオン)。 |
| F6 でグリッドが見えない | ゲーム画面ではグリッドを隠します。 | G を押します。 |
| フローティングウィンドウがエディターの外に出るのが不便 | 0.9.9 以降は OS のウィンドウとして表示されます。 | 環境設定 › 外観 › 「フローティングウィンドウをエディターの外へ」をオフにします。 |
| パネルの配置が崩れた | — | ウィンドウ › レイアウトをリセット をクリックします。 |
| 言語を変更したのにそのまま | 言語は再起動しないと変わりません。 | エディターを再起動します。 |
| 症状 | 原因 | 解決方法 |
|---|
| 保存せずに終了してしまった | — | 再起動して ファイル › 自動保存を読み込む をクリックします。開いた後、「名前を付けて保存」で保存します。 |
| 保存中に PC の電源が切れた | — | そのワールドを再び開きます。残っている .tmp・.bak から復元し、通知に「復元」と表示されます。 |
| 「レジストリを読み込めないため、空のレジストリで開始します」 | プロジェクトフォルダーの assets\registry.json を読み込めませんでした。 | そのファイルが削除されたり、他のプログラムに変更されたりしていないか確認します。 |
| Minecraft ワールドとして保存したワールドがシングルプレイの一覧にない | saves フォルダーに入れていません。 | 作成された <名前>_world フォルダーを %APPDATA%\.minecraft\saves\(または使っているランチャーの saves フォルダー)にコピーします。 |
| ゾーントリガーがシングルプレイのワールドで動かない | ワールドロジックはサーバープラグイン NP Scene が実行します。 | サーバー用ファイルをエクスポートウィンドウ(Ctrl+Shift+E)で作成します。エクスポートとインポート を参照。 |
| 症状 | 原因 | 解決方法 |
|---|
| プラグインが無効になっていてエラーが表示される | プラグインが例外を出すと、そのプラグインだけを無効にしてエディターは動作し続けます(隔離)。 | ツール › プラグインマネージャー… でエラー内容を確認して再読み込みします。ヘルプ › プラグイン一覧 に警告がまとめられています。 |
| プラグインが一覧にない | プラグインフォルダーにありません。 | ツール › プラグインフォルダーを開く で開いたフォルダー(%APPDATA%\NPEditor\plugins\)に入れます。 |
プラグインを作る側の問題は、プラグイン開発の概要 と SDK のトラブルシューティングのドキュメントを参照してください。
| 場所 | 内容 |
|---|
| 出力ログパネル | エディター・プラグインが出力したすべての通知とエラーです。下部エリアの「出力ログ」タブです。 |
| ログファイル | %APPDATA%\NPEditor\logs\ に実行記録のファイルが残ります。 |
| ヘルプ › プラグイン一覧 | 読み込んだプラグインと登録時の警告 |
| ヘルプ › 情報 / ライセンス | エディターのバージョン(問い合わせの際に一緒に伝えてください) |