界面布局
NP Editor 的界面布局与虚幻引擎 5 相似。从上到下依次为菜单栏、主工具栏、停靠面板与中央视口、状态栏。按钮以图标显示,将鼠标悬停在按钮上时,名称和快捷键会以工具提示显示。
| 编号 | 区域 | 作用 |
|---|---|---|
| 1 | 菜单栏 | 文件 · 编辑 · 窗口 · 工具 · 构建 · 帮助菜单,以及世界名称 · 目标版本 |
| 2 | 主工具栏 | 保存 · 模式 · 添加 · 运行 · 声音预览 · 放置方块 |
| 3 | 工具面板(「工具」) | 当前模式的工具与选项 |
| 4 | 视口 | 以 3D 方式查看和编辑世界的地方。上方浮现两条视口栏。 |
| 5 | 大纲 · 细节 | Actor 列表与所选对象的属性 |
| 6 | 下方区域 | 内容浏览器 · 输出日志 · 控制台及其他面板 |
| 7 | 状态栏 | 进度 · FPS · 坐标 · 选区大小 · 保存状态 |
菜单项旁的括号中显示当前使用的快捷键。更改快捷键后,此处文字也会随之改变。插件添加菜单时,新菜单会出现在「帮助」之前。
| 菜单 | 主要项目 |
|---|---|
| 文件 | 新建 · 打开… · 保存 · 另存为… · 加载自动保存 · 快速快照(全部) · 加载 jar… · 生成测试地形 (256×256×128,性能检查) · 用服务器 jar 生成方块列表… (目标版本) · 重新查找启动器文件夹 (版本列表) · 高分辨率截图… · 导入: 模型 (.bbmodel .npmodel .obj .gltf .glb .fbx) · 导入: .schem (Sponge 结构文件) |
| 编辑 | 撤销 · 重做 · 清除历史记录 (丢弃撤销步骤) · 清理空 Actor · 开关每个形状生成 Actor · 开关对称绘制 · 切换活动对称 · 开关辅助线吸附(放置·形状起点) · 锁定选区 (协作建造) · 放置评论图钉 (点击 · Esc 取消) · 隐藏快照差异 · 编辑器偏好设置… · 项目设置… |
| 窗口 | 所有面板(勾选表示已打开)· 显示「<区域> 区域」 · 最大化 / 还原视口 · 资源包 · 资产编辑器 (所选自定义) · 重置布局 |
| 工具 | UV 编辑器 · 切换绘制标签页 / 世界标签页 · 四分视图 · 运行 (第一人称行走) · 模拟 (自由相机 · 逻辑) · 将选区保存为预制件 · 世界逻辑 · 逻辑图 · 序列器 (动画·过场) · 创建区域触发器… (拖出区域 → 模板) · 设计工具 (材料清单·规划表·地图·移动距离·楼层视图)… · 性能设置… (视距·LOD·阴影·线程) · 快捷键… · 插件管理器… · 开关 AI 连接(MCP) 等 |
| 构建 | 导出: 资源包片段 · .npbuild (Ctrl+Shift+E) · 导出: markers.json (服务器标记) · 构建资源包 · 保存为 Minecraft 世界… · 导出生成格列表 (json) |
| 帮助 | 插件列表 · 关于 / 许可证 · 账户: 更改密码 · 账户: 退出登录(仅限使用登录的安装包) |
菜单栏最右侧有以下项目。
| 项目 | 内容 |
|---|---|
| 世界名称 | 当前世界文件的名称。尚未保存的新世界为「无标题」。鼠标悬停时显示完整路径。 |
| 更改标记点 | 有未保存的更改时会亮起一个小圆点。 |
| 目标版本 | 选择制作地图所用 Minecraft 版本的下拉框。参见 安装与首次启动 的「选择目标版本」。 |
| 位置 | 按钮 | 作用 |
|---|---|---|
| 左侧 | 保存 | 保存当前世界(Ctrl+S)。 |
| 左侧 | 模式行 | 方块笔刷 · 选择 · 地形景观 · 植被等模式按钮。超过 8 个时,其余模式位于 ▾「其他模式」中。 |
| 左侧 | 「添加」 | 快速添加。搜索方块 · 形状 · 道具 · 体积 · 灯光 · 标记,并放置在鼠标位置(无则放在屏幕中央前方)。Enter = 第一项。 |
| 中间 | 运行 · ▾ | 开始运行。在 ▾ 中选择方式(运行 · 模拟)和起始位置(当前相机位置 · 出生点)。 |
| 中间 | 暂停 · 单刻 · 脱离 · 停止 | 仅在运行时使用。参见 在运行模式中测试。 |
| 右侧 | 声音预览 | 开关音源预览并设置总音量。 |
| 右侧 | 放置方块 | 当前要放置的方块的图标和名称。 |
也可以用数字键切换模式。1~7 切换到方块笔刷,4 · 8 切换到选择,T 切换到地形景观模式。全部按键请参阅 快捷键。
初始布局如下。
| 区域 | 初始打开的面板 | 通过窗口菜单打开的面板(示例) |
|---|---|---|
| 左侧 | 工具 | — |
| 右上 | 大纲 | — |
| 右下 | 细节 | 历史 · 运行状态 |
| 下方 | 内容浏览器 · 输出日志 · 控制台 | 方块调色板 · 纹理 · 预制件 · 负载预算 · 快照 · 协作建造 · 声音 · 天空 · HUD · 序列器 · 世界逻辑 · 逻辑图 · 资源包 · 资产编辑器 |
| 面板 | 内容 |
|---|---|
| 工具 | 当前模式的工具图标网格与选项。图标的工具提示显示「名称 (键)」。 |
| 大纲 | 以名称 · 类型 · 眼睛 · 锁 · 方块数显示世界中的 Actor。带有搜索和文件夹。参见 场景 Actor 与大纲。 |
| 细节 | 以「名称 | 值」行显示所选 Actor · 方块 · 选区的属性。 |
| 内容浏览器 | 查找方块 · 预制件 · 模型 · 声音 · 纹理并拖放到视口。参见 内容浏览器。 |
| 输出日志 | 编辑器和插件输出的全部文字。简短通知也全部记录在这里。 |
| 控制台 | 以文字输入命令。fill · replace · select · tp · lookat · cam · shot · help 等。↑ ↓ = 之前的命令,Tab = 补全。~ 表示鼠标下方的格。 |
| 历史 | 撤销步骤列表。点击某行即可跳到该步骤。 |
| 操作 | 结果 |
|---|---|
| 将标签页拖到其他区域 | 移到该区域。 |
| 右键单击标签页 ›「移到左侧」等 | 移到该区域。 |
| 右键单击标签页 ›「转为浮动窗口」 | 将面板拆出为独立窗口。关闭窗口后会回到原区域。 |
| 右键单击标签页 ›「关闭」 | 关闭面板。可从窗口菜单重新打开。 |
| 窗口 ›「<区域> 区域」 | 显示或隐藏该区域。 |
| Ctrl+Space | 折叠或展开下方区域。没有打开的面板时打开内容浏览器。 |
| F11 · 窗口 › 最大化 / 还原视口 | 隐藏所有停靠区域,只显示视口。再按一次会恢复之前显示的区域。 |
| 窗口 › 重置布局 | 恢复为初始布局。 |
布局(区域 · 顺序 · 打开 · 折叠 · 分割位置)在下次启动时保持不变。
自 0.9.9 起:浮动面板和工具窗口以操作系统窗口的形式显示。可以移到编辑器窗口之外或其他显示器上。
适用的窗口包括浮动面板、编辑预制件、设计工具、导出、编辑器偏好设置、快捷键、插件管理器、性能设置、区域触发器向导、编辑公式、UV 编辑器、世界逻辑变量窗口。如果只想让它们留在编辑器界面内,请关闭 编辑 › 编辑器偏好设置… › 外观 ›「浮动窗口可移出编辑器」。已经打开的窗口在下次打开时生效。
对话框可用 Esc 关闭。主操作按钮是右下角的蓝色按钮。
视口上方浮现两条半透明的栏。
| 栏 | 按钮 |
|---|---|
| 左侧栏 | 视图类型(透视 · 上 · 下 · 前 · 后 · 左 · 右)· 视图模式 · 太阳 · 大气·光照 · 显示标志 |
| 右侧栏 | 选择 · 移动 · 旋转 · 大小操纵器 · 世界/局部 · 网格吸附 · 旋转吸附 · 相机速度 · 四分视图 · 最大化视口 |
点击左下角的坐标轴指示器即可切换到该方向的正交视图。各按钮的详细说明见 相机与视图。
视口右键菜单
Section titled “视口右键菜单”不拖动而直接按下右键时会弹出菜单。按住右键移动鼠标则是相机环视。
| 分组 | 项目 |
|---|---|
| 编辑 | 剪切 · 复制 · 粘贴到此处 · 复制 (旁边) · 删除 |
| 选择 | 选择 → 生成 Actor · 选择所有相同方块 · 仅选区内的相同方块 · 反选 |
| 视图 | 相机移到此处 · 放到地面 · 隐藏 · 显示所有隐藏项 |
| 快速添加 | 按分类的子菜单 — 放置在右键单击的格上。 |
简短通知会在视口右下角短暂显示后消失。相同的文字会保留在输出日志中。
位于界面最下方的一行。从左到右依次显示以下内容。
| 项目 | 内容 |
|---|---|
| 消息 | 最后一条通知文字。 |
| 大型操作进度 | 大型操作运行期间显示名称 · 进度条 · 取消按钮(Esc)。 |
| 选区大小 | 选区的大小(例:「选区 8×5×6」)或集合选择的格数。 |
| 网格化 | 等待生成绘制网格的区块数。鼠标悬停时显示详细数值。 |
| FPS | 最近的平均每秒帧数。 |
| 坐标 | 鼠标下方格的坐标。括号中的坐标是将要放置方块的格。 |
| 保存状态 | 「已保存」或「有更改」。 |
视口位置分为世界标签页和绘制标签页。可用 Ctrl+Tab 或 工具 › 切换绘制标签页 / 世界标签页 进行切换。绘制标签页显示期间,世界编辑按键会被屏蔽。参见 绘制与材质。