プレハブは、ブロックのまとまり(プロップを含む)を保存しておき、何度も置けるアセットです。家・街灯・塔のように繰り返し使うものをプレハブにします。リンクとして置いたものは、元のプレハブを編集すると一括で変わります。
| 方法 | 動作 |
|---|
| ウィンドウ › プレハブ | プレハブパネル(ライブラリ)を開きます。 |
| コンテンツブラウザ | 左のソースツリーの「プレハブ」で探します(タグごとのフォルダー)。 |
| ツール › 選択範囲をプレハブとして保存 | 現在の選択をすぐにプレハブとして保存します。 |
| プレハブをダブルクリック | プレハブ編集ウィンドウを開きます(プレハブパネル・コンテンツブラウザのどちらでも)。 |
- 選択ツール(Q)で、保存する建物をボックス選択します。
- プレハブパネル(ウィンドウ › プレハブ)の「選択範囲を保存」グループに名前・タグを書き、「選択範囲を保存」を押します。
- 一覧でプレハブを選び、「配置」を押します(またはビューポートへドラッグ&ドロップします)。
- ビューポートをクリックして置きます。R = 回転、F = 反転、Esc = 終了。
- 置くと選択ツールに切り替わり、置いたものが選ばれます。そのまま W・E・R で動かします。
- 直すときは、プレハブをダブルクリックして編集ウィンドウで直し、「保存」します。リンクされた配置済みのものがすべて変わります。
| 方法 | 結果 |
|---|
| プレハブパネル「選択範囲を保存」 | 「名前」・「タグ」(カンマ区切り)を付けて保存します。 |
| ツール › 選択範囲をプレハブとして保存 | 「プレハブ 月日_時分」という名前ですぐに保存します。名前はあとで変更します。 |
| アウトライナーの右クリック「小物(プレハブ)として保存」 | そのアクターのブロック・プロップだけをプレハブとして保存します。境界内のほかのアクターのマスは除かれます。 |
| モデル読み込みの「ブロックに変換」 | 外部モデルをバニラブロックに変換し、プレハブ(タグ「モデル変換」)として保存します(カスタムモデルの読み込み)。 |
選択内にブロックが1つもなければ保存されません。
| 操作 | 動作 |
|---|
| プレハブパネル「配置」・編集ウィンドウ「配置」 | 配置モードを開始します。 |
| プレハブパネル・コンテンツブラウザからビューポートへドラッグ&ドロップ | その位置で配置モードを開始します。 |
| クリック | マウスの下のマスにピボットを合わせて置きます。置いたあと選択ツールに切り替わります。 |
| Shift+クリック | 置いたあと配置モードを続けます(複数配置)。 |
| R・F | 90° 回転・左右反転(ブロックの向きも一緒に) |
| Esc | 配置終了 |
置いたプレハブ1つは、アウトライナーでアクター1つです。
プレハブパネルの「配置オプション」グループです。
| 欄 | 既定 | 意味 |
|---|
| リンクとして配置 | オン | 配置したものを元とつないでおきます。元を保存すると一緒に更新されます。 |
| 空きマスで消去 | オフ | プレハブの空きマス(空気)で、その位置の既存ブロックを削除します。 |
| プロップも配置 | | プレハブに含まれるプロップも一緒に置きます。 |
| 手を加えたブロックを維持 | | 一括更新のとき、置いたあとに手を加えたマスはそのまま残します。 |
- リンクとして置いたもの1つを、ワールド上で直接編集します。
- マウスカーソルをその上に置きます。
- プレハブパネルの「カーソル下のもので修正」を押します。
- プレハブが新しいリビジョンとして保存され、リンクされたものがすべて更新されます。Ctrl+Z 1回で元に戻します。
プレハブをダブルクリックするか、パネルの「編集」を押すと開きます。エディターの外へ移動できるフローティングウィンドウです。
0.9.10 以降: 編集ウィンドウの左側が、画像ではなく本物の 3D 編集ビューポートになりました。プレハブを置く → 穴を開ける → 選び直して保存する、という作業を1つのウィンドウで行えます。
プレハブのブロックだけが入った別のワールドです。メインワールド・メインの元に戻す履歴とは別に動きます。保存するまで、メインワールドは変わりません。
| 上の列 | 意味 |
|---|
| ツールボタン7つ | 配置 1・破壊 2・スポイト 3・選択 4・図形 5・ブラシ 6・塗りつぶし 7 |
| 配置ブロック・「メインのブロック」 | このウィンドウで置くブロック(ステートを含む)。「メインのブロック」= メイン画面の現在のブロックを取り込む |
| 表示 | アンリット (F2)・ライティング (F1)・ワイヤーフレーム (F3)・ゲーム画面 (F6)・パストレーシング (F7) |
- 最初に開いたときの表示はアンリットです。プレハブの最小の角が床グリッドの (0, 0, 0) に来ます。
- カメラ操作はメインビューポートと同じです。
| キー(ウィンドウにフォーカスがあるとき) | 動作 |
|---|
| 1 〜 7・Q・Tab | ツールの切り替え |
| W・E・R | 範囲ギズモ(選択があるとき) |
| R・Shift+R・X・Shift+X・U | 回転・反転 |
| 矢印キー・PgUp・PgDn・K | 移動・配列 |
| Del・Ctrl+C・Ctrl+X・Ctrl+V・Ctrl+I・Ctrl+A | 削除・コピー・切り取り・貼り付け・反転・全体 |
| [・] | ブラシ・図形のサイズ |
| F・G・H | 合わせて表示・グリッド・非表示 |
| F1 〜 F7 | 表示モード |
| Ctrl+Z・Ctrl+Y | このウィンドウ内の元に戻す・やり直し |
| Esc | ドラッグのキャンセル → 選択解除 |
| タブ | 内容 |
|---|
| プレハブ | 名前・タグ・ピボット・向きを固定・ブロック一覧・サイズとリビジョンの情報 |
| ツール | ブロックステート・パターン・図形・ブラシ・塗りつぶし・選択範囲の操作・ブロック置換(メインのツールパネルと同じ) |
| 「プレハブ」タブの欄 | 意味 |
|---|
| 名前・タグ | タグはカンマで区切ります(例: 城壁, 中世)。 |
| ピボット(配置の基準) X・Y・Z | 置くときにカーソルのマスに来る、プレハブ内のマス。「底の中央」= 底の中央に |
| 向きを固定 | 「Y 90° 回転」・「左右反転」— ブロックを回転・反転して保存します(置くときの既定の向きが変わります)。 |
| ブロック | ブロックの種類ごとの個数一覧。選んだブロックを「変更」(別のブロックに)・「削除」(空気に) |
| 下部のボタン | 動作 |
|---|
| 保存 | 同じプレハブの新しいリビジョンとして保存します。ブロックが変わっていれば、ワールドでリンクされた配置済みのものも更新します。 |
| 配置 | 保存してから配置モードを開始します。 |
| 新しいプレハブとして複製 | 別のプレハブとして保存します(リンクは元のまま)。 |
| ファイルに書き出す | .npprefab ファイル1つに書き出します。 |
| 閉じる | 保存していない変更があれば、「破棄して閉じる」・「編集を続ける」を尋ねます。 |
- ピボットだけを変えて保存した場合、すでに置いたものは位置がそのままです。
- 更新された配置済みのものは、元々属していたアクターにそのまま残ります。
- ブロックが1つもないプレハブは保存できません。
- プレハブを保存すると、上書きせずに新しいリビジョン(
r2、r3 …)を作ります。ファイルは <名前>_v2.npprefab のように新しく作られます。
- ライブラリには、同じプレハブのうち最も高いリビジョンだけが表示されます。古いリビジョンのファイルはフォルダーに残ります。
- 名前の変更: プレハブパネルの「名前」(F2)またはコンテンツブラウザの右クリック「名前を変更」。同じプレハブの新しいリビジョンになり、配置済みのものとのリンクはそのままです。
| したいこと | 方法 |
|---|
| エクスポート | プレハブパネル「エクスポート」・編集ウィンドウ「ファイルに書き出す」・コンテンツブラウザの右クリック「ファイルに書き出す…」(複数選ぶとフォルダーに) |
| インポート | プレハブパネル「インポート」・コンテンツブラウザ「インポート」で .npprefab ファイルを選ぶ |
インポート時のルールは次のとおりです。
| 場合 | 結果 |
|---|
| 初めて見るプレハブ | ライブラリに追加します。 |
| 同じプレハブのより高いリビジョン | 最新に更新します。 |
| 同じプレハブの同じか低いリビジョン | 上書きせず、コピーとして追加します。 |
| 設定 | 場所 | 意味 |
|---|
| リンクとして配置・空きマスで消去・プロップも配置・手を加えたブロックを維持 | プレハブパネル › 配置オプション | 上の「配置オプション」の表 |
| 名前・タグ | プレハブパネル › 選択範囲を保存 | 新しいプレハブの名前とタグ |
| 検索・タグ | プレハブパネル上部 | 名前・タグで絞り込み |
| ピボット・向きを固定 | 編集ウィンドウ › プレハブタブ | 置く基準と既定の向き |
| キー | 動作 |
|---|
| R・F(配置中) | 回転・反転 |
| Shift+クリック(配置中) | 続けて配置 |
| Esc(配置中) | 配置終了 |
| F2 | 名前を変更(プレハブパネル・コンテンツブラウザ) |
| ダブルクリック・Enter | 編集ウィンドウを開く |
編集ウィンドウ内のキーは、上の「3D 編集ビューポート」の表を参照してください。
- プレハブファイルは、プロジェクトフォルダーの
prefabs/ に保存されます。ワールドをまだ保存していなければ、ユーザーフォルダー(%APPDATA%\NPEditor\prefabs)に保存されます。
- リンク情報はワールドファイル(.npworld)に保存されます。プレハブファイルだけをほかの PC に移しても、リンクは付いていきません。
- プレハブ1つは最大約1,677万マスです。
- 面の押し出しの「途中モジュール」で、プレハブを壁の間に N マスごとに挟めます。
- プレハブ編集ウィンドウの元に戻すは、ウィンドウ内でだけ効きます。保存によってワールドに反映された更新は、メインで Ctrl+Z で元に戻します。