コンテンツにスキップ

空とサウンド

空の装飾は、太陽・月・雲の画像をエンジンが直接描き、リソースパックとシェーダーパックに入れる機能です。バニラの空の画像は読み込みもコピーもしません。サウンドライブラリは、サウンドイベントとサウンドファイルを管理します。サウンドエミッターアクターは、洞窟の水滴・滝のように、決まった位置で音を鳴らします。

内容開く場所
空の装飾ツール › 空の装飾 → 下部領域の「空」パネル
サウンドライブラリツール › サウンドライブラリ → 下部領域の「サウンド」パネル
サウンドエミッターを配置メインツールバー「追加」› サウンド
サウンドプレビューメインツールバー右側のスピーカーボタン(ツールチップ「サウンドプレビュー」)

2 つのパネルは「ウィンドウ」メニューからも表示/非表示を切り替えられます。

  1. ツール › 空の装飾 を開きます。
  2. 「太陽」欄で「形」・「色」・「サイズ」を選びます。
  3. 「月」・「雲」欄も同じように選びます。
  4. 「昼」・「夜」を押すと、F6 ゲーム画面で 13 時・23 時の空を確認できます。
  5. 値はすぐにプロジェクトの assets/sky.np.json に保存されます。
  6. 「リソースパックを作成」と「シェーダーパックを作成」を行うと、空も一緒に含まれます。
  1. ツール › サウンドライブラリ を開きます。
  2. 上の欄に新しいイベント id を入力して「イベント」を押します(例: noplatea:ambient.cave_drip)。
  3. イベントを選び、「ファイルを追加…」で .ogg または .wav を入れます。
  4. 再生アイコンを押して聞いてみます。
  5. メインツールバー「追加」› サウンド ›「洞窟の水滴」などでサウンドエミッターを配置します。
  6. 詳細パネルで、エミッターの「イベント」を先ほど作成した id に変更します。
  7. ツールバーの「サウンドプレビュー」をオンにし、カメラを近づけて聞いてみます。
欄選べるもの
太陽・形バニラのまま・柔らかい太陽(光輪)・ピクセル太陽・リング付き太陽・星形・日食
太陽・色暖かい白・金色・夕焼けオレンジ・冷たい白・バラ色
太陽・サイズ / グロー / シード0.5〜1.5 / 0〜1 / 模様のシード
太陽・シェーダーで描画オンにすると、シェーダーパックがこの形を直接描きます。オフにすると、リソースパックの太陽の画像を使います。
月・形バニラのまま・クレーターの月・ピクセルの月・三日月の絵・光輪の月
月・色既定(銀色)・血の色・青い月
月・プレビュー位相F6 で表示する位相(満月 〜 十三夜月、8 種類)です。ゲームでは日付に従って変わります。
雲・形バニラのまま・積雲・巻雲(筋状)・ちぎれ雲(まばら)・雲なし
雲・雲の量 / 塊の大きさ0.05〜0.9 / 0.5〜2
雲・シェーダー雲レイヤーシェーダーパックが空に 2D の雲レイヤーを描きます。バニラの雲は隠します。「高さ (シェーダー)」・「流れ (シェーダー)」も一緒に設定します。
雲・立体の雲(シェーダー)シェーダーの雲レイヤーを立体の雲に変えます。「厚さ(立体)」・「品質(立体)」(0 低・1 中・2 高)
画像サイズ・太陽・月×1 (32×32)・×2 (64×64)・×4 (128×128)
画像サイズ・雲マップ×1 (256×256)・×2・×4 (1024×1024、リソースパックのセルフチェックで警告)
旧パスも旧クライアント用の画像パスも一緒に入れます。
「バニラに戻す」すべての欄をバニラのままに戻します。リソースパックに空の画像を入れません。
  • 同じシードなら同じ画像になります。シードを変えると模様が変わります。
  • 月の色(血の色・青い月)は、「シェーダーで描画」をオフにしてもシェーダーが乗算します。

0.9.7 以降: 「立体の雲(シェーダー)」が追加されました。ゲームのシェーダーパックと F6 の空が同じ計算で描きます。

種類どこで聞こえるか作成されるもの
新規イベント (<ns>:…)サーバー(プラグイン・サウンドエミッター)が再生したときリソースパック assets/<ns>/sounds.json + ogg
バニラ置換 (minecraft:…)すべての場所(リソースパックだけで)リソースパック assets/minecraft/sounds.json "replace": true
イベントの欄意味
字幕字幕の翻訳キーまたは文言です。空にすると字幕はありません。
ファイル (assets/sounds)イベントが使うファイルの一覧です。複数ある場合はランダムに 1 つを再生します。
音量・ピッチ・重みファイルごとの大きさ・音の高さ・選ばれる比率です。
長いサウンドBGM・長いループではオンにします。Minecraft が分割して読み込みます。
状態ファイルがない、または形式が誤っている場合に表示されます。
ボタン動作
「イベント」上の欄の id でイベントを作成または選択します。
「バニラを置換」置き換えるバニラのサウンド id を一覧から選びます。
「スターターサウンドを作成」エンジンが直接合成したサウンド(洞窟の水滴・小川・滝・焚き火・風・洞窟の反響・チャイム・石/木/水晶ブロック)を np:… イベントとして入れます。既存のイベントはスキップします。
「ファイルを追加…」.ogg・.wav をイベントに入れます。.wav は Ogg に変換します。
「モノラル化」チェック(既定でオン)位置のある(3D)サウンドをモノラルに変換して入れます。
再生アイコンイベントを 1 回再生します(重みに従ってランダムなファイル)。
除外アイコン・削除アイコン選択したファイルをイベントから外します・イベントを登録簿から削除します。
更新アイコンassets/sounds.np.json を再読み込みします。
  • ファイルは assets/sounds/<ns>/<パス>.ogg にコピーされます。同じ名前がある場合は _v2・_v3 を付け、上書きはしません。
  • イベントを削除したりファイルを外したりしても、ディスク上のサウンドファイルは削除しません。
  • 位置のあるサウンドは、モノラルでないと距離に応じて小さくなりません。ステレオは距離に関係なくそのまま耳に聞こえます。
  • サウンドを 1 つずつレシピ・シードで合成する機能は、AI 接続の sound_generate ツールにあります(AI 接続 (MCP))。

カスタムブロックは音符ブロックの状態として作られるため、クライアントのサウンドが固定です。そのため、サーバープラグインが代わりにサウンドを再生します。

欄意味
破壊・配置・歩く・叩く・落下ブロックごとに、この 5 つの瞬間に再生するイベント id です。空にすると既定のサウンドです。
登録済みイベントから選択ライブラリのイベント一覧から選びます。

ブロックのサウンドは、サーバー登録簿をエクスポートするときに <名前>_sounds_server_vN.json の block_sounds として出力されます。

「追加」› サウンド既定
洞窟の水滴間隔ごとに 1 回
滝・水の流れ連続ループ
焚き火のパチパチ間隔ごとに 1 回
風連続ループ
空のサウンドエミッターイベントなし
詳細の欄意味
イベント再生するサウンドイベントの id です。右のボタンで、ライブラリ・バニラの候補から選びます。
中心サウンドが鳴る位置(ブロック座標)です。「マウスの下に移動」で移動します。
聞こえる距離この距離(ブロック)でサウンドが 0 になります。
方式間隔ごとに1回 (random)・連続ループ (loop)
間隔 (秒)最小 〜 最大の間でランダムに待ちます(random 方式)。
音量・ピッチ大きさと音の高さ(0.5〜2、最小 〜 最大の間でランダム)です。
時間帯常に・昼のみ・夜のみ(昼 = 06〜18 時)
地下のみ上が塞がれた場所(洞窟)でのみ再生します。
  • ゲームでは、サーバープラグインが sounds_server.json の sound_emitters を読み込み、この位置・周期で再生します。
  • エディターでは、「サウンドプレビュー」をオンにすると、カメラから 64 ブロック以内のエミッターが聞こえます。プレイ中は常にオンです。
  • コンテンツブラウザの「サウンド」項目をビューポートへドラッグ&ドロップしても、サウンドエミッターが作成されます。
設定場所意味
サウンドプレビューメインツールバーオン/オフ(既定でオフ)
全体音量メインツールバーのスピーカーの横のスライダープレビューの全体音量(既定 0.8)

この機能専用のショートカットはありません。詳細パネルの「カメラを合わせる (F)」は、選択したエミッターにカメラを移動します。

  • バニラのサウンドファイルはエディターに含まれていません。バニラのイベントは、ファイルを入れないとエディターでは聞こえません。
  • バニラ置換イベントにファイルがないと、ゲームでそのサウンドが鳴りません(無音)。
  • サウンド・空は完成リソースパックにのみ含まれます。ピース方式では警告だけを出します。
  • 空の画像は独自の数式で描いた画像なので、そのまま配布できます。
  • 10 秒を超えるサウンドは「長いサウンド」をオンにします。